+ Reply to Thread
Results 1 to 20 of 20
  1. #1
    Cornfused MGuzzy's Avatar
    Join Date
    08-27-2003
    Location
    Sacramento, CA
    Posts
    2,810

    Loading v 1.9.2 on a Samsung i730 w WM5

    Howdy...
    I've been trying to get PhoneDashboard 1.9.2 loaded on a Samsung i730 with Windows Mobile 5.0 with no success. It locks up the device every time. The install seems to succeed and it looks like it hangs as it loads the plugin. I can only clear the issue with a hard reset. I can load 1.1.8 without any problems but any other updates that you've released since cause the device to lock. Any suggetions?
    Sure would like to check out the WM5 enhancements.
    Mark
    Luck is where opportunity meets preparation.

  2. #2
    Born Again Convergin ChrisSpera's Avatar
    Join Date
    01-06-2004
    Location
    Oswego, IL
    Posts
    997
    The i730 is a CDMA phone, which is different than many of the GSM phones out there today running WM5. The device runs differently with the different cell radio in it. I'm not entirely certain why, but it does. My guess is that Noah would have to go and purchase an i730 to see exactly what is going on with it in debug mode to get a handle on what is making the device hang when it tries to load the plug in... Unless he has an idea off the top of his head...

    Noah..??
    Kind Regards,
    Christopher Spera
    Gear Diary Review Team

  3. #3
    Converged
    Join Date
    09-15-2003
    Posts
    81
    Mark - thanks for bringing this to our attention - we have had a couple other reports from Samsung i730 users running WM5 as well. I have an idea for what is going on, but I am not totally sure. I would like to try one thing before I get the i730 device in house.

    To Chris' point, there is something different about the radio on the i700/i730 devices from Samsung - a function call to obtain information about the network operator and signal strength caused the phone to crash / have a memory leak. We put code in Phone Dashboard to try and detect the Samsung devices, and then disable the offending function calls. We look for a Samsung entry in the registry, and we also check the OEM string as well as the build of the OS.

    What I am thinking might be happening is that these checks are failing on the i730 with WM5.

    Mark - can you post the following info from your Pocket PC About Screen:

    (Start | Settings | System | About)

    OS Version and Build Number?

    I will then try and update the code to check appropriately on the i730. We could then try one more install on your device - if that doesn't work, I will get the device here for more testing. If you don't want to risk another hard reset, I understand however.

    Best,
    Noah
    (Hudson Mobile)
    Hudson Mobile Technologies, LLC
    Software for Networked Devices
    www.hudsonmobile.com

  4. #4
    Cornfused MGuzzy's Avatar
    Join Date
    08-27-2003
    Location
    Sacramento, CA
    Posts
    2,810
    Noah
    Figgers...I would have to get the "special" phone. Do you have these issues on other CDMA phones, say like the Treo700w? Just curious. Anyway, thanks for the attention. If there is anything I can do to help by way of beta and testing count me in.. If you want to use me as guinea pig, I don't have any problem reseting my phone for the cause, especially if it will serve to make your software available to more people. You can PM me and email me as well.

    Here's the information you requested:
    My OS version is: 5.1.195 build 14928.2.2.0
    And my PDA version is: S:i730WM5.2.6V.ZB21.14928

    Mark
    Luck is where opportunity meets preparation.

  5. #5
    Converged
    Join Date
    09-15-2003
    Posts
    81
    Mark -

    Thanks for your willingness to use your device for the cause and for the info. I will build you a version that checks correctly for the i730 with WM5 and we will see if it helps the situation. If not, I checked ebay and the cost of a i730 is about $150 - so, I will get one and get it to work if this doesn't pan out.

    Regarding your question, the 700w works great - it is the phone I use day to day - this issues seems to be specific to Samsung devices - it was there on the i700 as well (which I owned).

    Best,
    Noah
    Hudson Mobile Technologies, LLC
    Software for Networked Devices
    www.hudsonmobile.com

  6. #6
    Cornfused MGuzzy's Avatar
    Join Date
    08-27-2003
    Location
    Sacramento, CA
    Posts
    2,810
    Thanks... I look forward to your next posting
    Mark
    Luck is where opportunity meets preparation.

  7. #7
    Born Again Convergin ChrisSpera's Avatar
    Join Date
    01-06-2004
    Location
    Oswego, IL
    Posts
    997
    Phone Dashboard works EXTREMELY well on the WM Treo 700 Series. I've had the app running on a 700w while I had it, and currently on the 700wx. No problems at all...
    Kind Regards,
    Christopher Spera
    Gear Diary Review Team

  8. #8
    Converged
    Join Date
    09-15-2003
    Posts
    81
    Mark - I have sent you an email with a link to the test version. Please respond by email and let me know how it goes.
    Hudson Mobile Technologies, LLC
    Software for Networked Devices
    www.hudsonmobile.com

  9. #9
    Born Again Convergin ChrisSpera's Avatar
    Join Date
    01-06-2004
    Location
    Oswego, IL
    Posts
    997
    would love to know how this is going. Please comment back when you have results!
    Kind Regards,
    Christopher Spera
    Gear Diary Review Team

  10. #10
    Registered User
    Join Date
    12-07-2006
    Posts
    9
    i have been looking for a fix for this for a few days. finally stumbled across this post. i have the same phone but with 2003 on it. i am having the same problem. praying for a fix

    so any updates on this would be great.

    edit: i did find a easier way around the lockup besides hard reset. if you soft reset your phone 2, sometimes 3, times before i 'locks up' you can boot into safemode and remove the conflicting program, im sure this is posted somewhere, but for those that look at this thread it might be helpful.
    Last edited by mipstien; 12-07-2006 at 06:28 PM.

  11. #11
    Cornfused MGuzzy's Avatar
    Join Date
    08-27-2003
    Location
    Sacramento, CA
    Posts
    2,810
    Yeah you have to have a safe mode utility loaded on your phone first...like Ilauncher, Pocket plus or SafeMode. The first time I came upon this I had to do a hard reset becuase I had no safemode utility installed. Mipsiten, you should be able to run an earlier version. I was able to run v1.1.8 alright... I think that was the last version for WM2003.
    Mark
    Luck is where opportunity meets preparation.

  12. #12
    Registered User
    Join Date
    12-07-2006
    Posts
    9
    so im assuming the test version didn't work either?
    i had such high hopes for this program
    im not even sure where to find 1.1.8

  13. #13
    Registered User
    Join Date
    12-07-2006
    Posts
    9
    i believe my phone came with a safe mode utility built in. i never did install one. i can hard reset and go immediatly into safe mode also.

  14. #14
    Converged
    Join Date
    09-15-2003
    Posts
    81
    The test version didn't work unfortunately. I now have a i730 device in house and will be working on reproducing the issue here. It is also news that 1.9.2 has this issue even on devices running WM2003 - we have not heard that before and have had other folks who seem to be running OK. I will test both and see what happens.
    Hudson Mobile Technologies, LLC
    Software for Networked Devices
    www.hudsonmobile.com

  15. #15
    Converged
    Join Date
    09-15-2003
    Posts
    81
    Good news! I was able to quickly isolate the bug once I got the device and debug logging working to the storage card. Essentially, on initial setup one of the code paths was still hitting the "forbidden library", even though the check for the Samsung device was working accurately. So, at least on the WM2003 build I have, fixing that issue has gotten the program to load correctly. Note that the Signal Strength and Operator Name features will not work on the Samsung devices because of this issue, but the core call tracking will.

    MGuzzy - I have emailed you the link to the debug version to try it on your device.

    mipstien - please send me your email address (send it to our support email alias - you can find it on our website - I don't want to post it here due to spam) and I can email you the debug version as well.

    If the feedback is good from this, I will post the fix for everyone.
    Hudson Mobile Technologies, LLC
    Software for Networked Devices
    www.hudsonmobile.com

  16. #16
    Converged
    Join Date
    09-15-2003
    Posts
    81
    OK - looks like the feedback is good - the new build seemed to fix the i730 issue on both WM2003SE and WM5. I have posted the new version to Handango and PocketGear as 1.9.3.
    Hudson Mobile Technologies, LLC
    Software for Networked Devices
    www.hudsonmobile.com

  17. #17
    Cornfused MGuzzy's Avatar
    Join Date
    08-27-2003
    Location
    Sacramento, CA
    Posts
    2,810
    Awesome.. I'm off to download the official release and give it a spin.
    Mark
    Luck is where opportunity meets preparation.

  18. #18
    Registered User
    Join Date
    12-07-2006
    Posts
    9
    i havne't had a chance to test out the newest version quite yet, but i am about to reload my phone cause i got a new 2 gig ultraII sd card. i will have to try it.
    i was wondering if this version supported verizon to verizon or mobile 2 mobile minutes? the version i have doesn't seem to count it, that i know of.

  19. #19
    Born Again Convergin ChrisSpera's Avatar
    Join Date
    01-06-2004
    Location
    Oswego, IL
    Posts
    997
    The current version counts M2M minutes. In the main config screen, you have to scroll down the list. M2M isn't turned on by default, and then you have to list which numbers to bucket as M2M.
    Kind Regards,
    Christopher Spera
    Gear Diary Review Team

  20. #20
    Registered User
    Join Date
    12-07-2006
    Posts
    9
    well i saw it but i haven't been able to point the program at the right numbers, maybe i just need to sit down for a long while and do it.
    maybe while im goin across the causeway today ill look at it.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts