Nevermind - duh - I must have looked at it 5 times. It is under Tools -> Preferences -> (disable) Show completed items.

Using Palm Desktop 4.1.0 with my 7135, it looks different at home and at work. My home one does not show completed items, which is what I want, but my work one does. I cannot find any menu or right-click option so that it does not show the completed items. Any way to do that?