+ Reply to Thread
Results 1 to 6 of 6
  1. #1
    Registered User
    Join Date
    10-12-2004
    Posts
    44

    ActiveSynce Restore problems

    I have an Audiovox PPC-6600. My unit hard reset after a fall. I set my
    ActiveSynce 3.8 to incrementally backup after every connection.

    The last backup that I seem to have is on 5/16/2005. My outstore.dat and repl.dat files are dated today 5/20/05. I also have an old backup dated 4/15/2005 that had problems with the Outlook email (there is a group of undeleteable email in the Outlook account).

    I've tried to restore with my current backup and I get the following message: "Restore: Invalid Storage File Version" "The selected backup file was created by an incompatible version of backup. Please select another storage file"

    I know the following:
    1.. The Pocket PC OEM, model number and rom release must be the same as
    the one when the backup is performed.

    2.. The Pocket PC must be the same language as the backup was performed
    with.

    3.. You must set the regional settings the same as when the backup
    occurred

    http://www.cewindows.net/faqs/activesync/backup.htm

    None of these things have been changed and I've tried the 2 time zones that I've been in the last week to no avail. Are there any any other suggestions to get around this issue? Is there a way to view the backup.stg file to see what of the above settings it is expecting? Some type of backup.stg reader. I have found the STGViewer but need the settings that it expects from the PDA.

    As an alternative, If I restore with my old backup, do you know how to fix the issue where some email are not able to deleted?

    Any help would be greatly apprecited.

  2. #2
    Registered User TomD's Avatar
    Join Date
    08-26-2003
    Location
    N.E. Ohio
    Posts
    157
    I found this on another site:

    "This happens when you perform a hard reset and on the time zone you select a specific one, when the backup is made you perform the hard reset and afterwards when setting up unit you select a different time zone from which the backup was created. Try performing another hard reset and setting the time zone correctly, try the default option or the one bellow or upper from your normal option. Instead of the full reset you can always tap on the clock option and reset you time zone. Update when you can. "

    Activesync backup/ restore has always messed up email accounts during the restore. MS is even aware, but I don't think it has ever been fixed. I use XBackup now and don't have that problem. You will find each email account stored under activesync rather than having their own folders. The only way I ever found to fix the email problem is to delete and recreate each email account from the Pocket PC after an activesynch restore.

    TomD.



    I don't know about the other problem, exept what I found on the other site (hp.com forums)

  3. #3
    Registered User
    Join Date
    10-12-2004
    Posts
    44
    As I've already mentioned, I've already tried the time zone issue. I just got off a plane from Texas to NY on Sunday the 15th. I changed time zones from visiting Central US to home @ Eastern US. I did a sync and backup on the 16th.

    I've tried restoring from both those time zones. I know it wasn't at one of the other time zones becasue I just chnaged it the day before syncing.

    I'm going to try every one.

  4. #4
    Registered User TomD's Avatar
    Join Date
    08-26-2003
    Location
    N.E. Ohio
    Posts
    157
    Here's a program that let's you see and copy what's in your stg files:

    http://www.pocketgear.com/software_d...id=262&afsrc=1

    It is freeweare.

    TomD.

  5. #5
    Registered User TomD's Avatar
    Join Date
    08-26-2003
    Location
    N.E. Ohio
    Posts
    157
    Nevermind, I see you already found STG Viewer.

    Anyone else experience this?

    TomD.

  6. #6
    Registered User
    Join Date
    10-12-2004
    Posts
    44
    I first used the Add/Remove Programs applet in ActiveSync to reinstall the programs that it thought should be installed.

    Using the STG Viewer, I found a file called restore.fdf in the Windows directory. I looked at it with notepad and it looked like a registry hive. So I donwloaded the PHM registry editor and imported it. Wa La - I got my registry back. All the settings that I didn't want to reconfigure. My Bluetoooth connections, VPN connections and the such all reappeared. ActiveSync even recognized the partnership.

    I then used the STG Viewer to copy the files I wanted to my computer first then to the phone (can't copy directly). I synced up and moved the items that went into Deleted items into their original locations and let the sync take place again.

    I then backuped with Activesync again. It said the backup that I just used the STG Viewer on was bad, so it overwrote it. Maybe later I will do a hard reset and test the restore.

    I will also use the PHM regisstry editor to partially backup my registry for restore after I do the WMP10 upgrade. I did the upgrade last night and back-reved because I couldn't get the 3900B bluetooth stack to not give me memory errors. Next time I'll try it BT3900B with a clean WMP10 install unlike what I did last night.

    FYI:
    I was able to restore my ActiveSynvc back dated 4/15/2005 over WMP10 despite the ROM upgrade. This is not supposed to work but it did with some minor problems.
    Last edited by KenGraham; 05-23-2005 at 11:19 PM.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts