+ Reply to Thread
Page 1 of 2 1 2 LastLast
Results 1 to 20 of 30
  1. #1
    Registered User
    Join Date
    12-15-2005
    Location
    Out West
    Posts
    198

    Using a VPN to access home computer?

    I tried to search for this, but the forum's search function appears to be down. If anyone knows of a thread that already covers this, please (flamelessly) post the link.

    I recall in other threads several people said they use a VPN connection, rather than pcAnywhere or the like, to access their home computers remotely with their 6600 over the Internet.

    What are the actual steps to set up the pocket PC to access a home computer via VPN and Remote Desktop?

    Seems like it should be not too hard, but I haven't been able to figure it out. I've found scraps of info scattered around the Web, but what I've found is either too vague or too tech-speak for my feeble mind.

    Thanks in advance.

  2. #2
    Editor and Site Administrator Convergent's Avatar
    Join Date
    11-16-2002
    Location
    Raleigh, North Carolina, United States
    Posts
    9,440
    Search isn't down... what happened that led you to believe that it was? Did you get an error message or anything. If so, please post it in the Site Problems forum so we can look into it. I just tried search and it seemed to be working fine.
    Mike - Been Converged?

  3. #3
    Registered User
    Join Date
    12-15-2005
    Location
    Out West
    Posts
    198
    That's odd -- search is working for me now, too. A few minutes ago it was telling me there were no hits for various things that I tried searching for, even very common words to test the search function. ... Thanks, I'll keep digging.

  4. #4
    Registered User
    Join Date
    11-04-2004
    Location
    Prince George, BC
    Posts
    49

    Arrow

    Quote Originally Posted by SeaRaven

    ...

    What are the actual steps to set up the pocket PC to access a home computer via VPN and Remote Desktop?

    Seems like it should be not too hard, but I haven't been able to figure it out. I've found scraps of info scattered around the Web, but what I've found is either too vague or too tech-speak for my feeble mind.

    Thanks in advance.
    Let's not get too far away from what was being asked here though... yes the search is probably working just fine... but what about VPN? I've tried to get that going as well, and think I got it all in place except I didn't have a machine that could issue the certificates.... that said, I also realize I may have still been way off... step by step instructions would be great.... or just a point in the right direction (if they are already out there) would be appreciated... In particular (for myself anyway) a WinXP Pro description would be great, everything I keep reading was talking about other versions of Win (which had certificate issuing mechanisms in place).

    Thanks for your time,
    Tyler

  5. #5
    Registered User supercluver's Avatar
    Join Date
    01-18-2006
    Location
    Sugar Land, TX
    Posts
    53
    This is the site I used to get my XP VPN-Server working on my home box.
    http://www.windowsnetworking.com/j_helmig/xpvpnsrv.htm
    If your VPN-Server is behind a router, you need to be able to set up the router for port forwarding. This site says you can't do this when behind a router, but you can if your router supports port forwarding. Also, if you have a dynamic IP vs a static IP there are somethings to consider there. Generally, even a dynamic IP won't change unless you disconnect for some period of time. But you must know your IP for this to work.

    As far as on my 6600, I went into the Connections settings, and added a VPN server under "My Work Network" by putting in the XP VPN-Server IP and picking PPTP as the VPN type. Then put in the username and password that you have set up on your server.

    A side note, I then run a free proxy server on my XP VPN-Server, select the "This network connects to the Internet" check box, and the "This network uses a proxy server to connect to the Internet" check box, and put in the servers IP address as the proxy server. After connecting to Sprint's VISION, I connect to my VPN and can surf the web and it bypasses Sprints image compression so my images don't get all distorted. Not a big deal, but sometimes its nice to be able to do that.

  6. #6
    Registered User
    Join Date
    11-11-2005
    Location
    Westminster, MD
    Posts
    50
    I used the exact same settings you mentioned, but no luck. I can get active sync to connect through the vpn, but I can't file browse.

    Quote Originally Posted by supercluver
    This is the site I used to get my XP VPN-Server working on my home box.
    http://www.windowsnetworking.com/j_helmig/xpvpnsrv.htm
    If your VPN-Server is behind a router, you need to be able to set up the router for port forwarding. This site says you can't do this when behind a router, but you can if your router supports port forwarding. Also, if you have a dynamic IP vs a static IP there are somethings to consider there. Generally, even a dynamic IP won't change unless you disconnect for some period of time. But you must know your IP for this to work.

    As far as on my 6600, I went into the Connections settings, and added a VPN server under "My Work Network" by putting in the XP VPN-Server IP and picking PPTP as the VPN type. Then put in the username and password that you have set up on your server.

    A side note, I then run a free proxy server on my XP VPN-Server, select the "This network connects to the Internet" check box, and the "This network uses a proxy server to connect to the Internet" check box, and put in the servers IP address as the proxy server. After connecting to Sprint's VISION, I connect to my VPN and can surf the web and it bypasses Sprints image compression so my images don't get all distorted. Not a big deal, but sometimes its nice to be able to do that.

  7. #7
    Registered User supercluver's Avatar
    Join Date
    01-18-2006
    Location
    Sugar Land, TX
    Posts
    53

    little more info please.....

    5harkology, perhaps a bit more info?? How are you trying to browse your shared folders?
    I share a folder on any of my computers on my home network. I connect to my VPN and then using Resco Explorer v5.21, I map a network drive.

    For example, I have the "My Documents" folder shared on my XP box that is also my VPN server. Under its permissions, everyone can access and modify it and its contents. Only myself and my wife can connect to my VPN server however. After I connect to my VPN on my 6600, I can map that folder in Resco File Explorer and browse its contents. That is how I do it.

  8. #8
    Registered User
    Join Date
    12-15-2005
    Location
    Out West
    Posts
    198
    Forgive my ignorance ...

    When port forwarding to set up a VPN on the deskptop PC behind a router, how do I know what to put in the "application" field?

    Ports to forward to are 1723 for TCP and 500 for UDP?

    (router - Linksys WRT54GS
    firmware- v2.07.1, Feb. 26, 2004)
    Last edited by SeaRaven; 01-29-2006 at 02:03 AM.

  9. #9
    Registered User supercluver's Avatar
    Join Date
    01-18-2006
    Location
    Sugar Land, TX
    Posts
    53

    I think you have it made easy....

    Quote Originally Posted by SeaRaven
    Forgive my ignorance ...

    When port forwarding to set up a VPN on the deskptop PC behind a router, how do I know what to put in the "application" field?

    Ports to forward to are 1723 for TCP and 500 for UDP?

    (router - Linksys WRT54GS
    firmware- v2.07.1, Feb. 26, 2004)
    Check out this page.... http://www.tomsnetworking.com/Sectio...le49-page1.php
    I believe your router supports VPN pass-through, so you just check the box for that and reboot your router.
    If I am mistaken, then you are right about the ports being 1723 for TCP and 500 for UDP. The application field is just the name you give the specific port forwarding you are doing. Since Microsoft's PPTP protocol uses 1723, I'd put "PPTP" in the application field for that, and 500 is used for ISAKMP Key negotiations used in IPsec based VPNs so for that I'd put "IPsec". The built in VPN Server in XP is only PPTP based VPN, so you don't really need to port forward UDP 500 since you can't do this unless you are using some other VPN server on your box.

  10. #10
    Registered User
    Join Date
    12-15-2005
    Location
    Out West
    Posts
    198
    Yep, I enabled VPN pass-through and rebooted the router, but it didn't help.

    I'm able to control the home desktop with pcAnyhere, but as far as I can tell, that program doesn't do remote file sharing and sync. My understanding is that VPN can do those things, yes?

    On my PPC, I:
    - Entered my home PC's external IP address in the "Host name/IP: field.
    - Set the VPN type as PPTP
    - correctly entered the usename and password for my home pc
    - left "Use server-assigned IP address" checked (should I check "Use specific IP address" instead, and if so, what address should I enter?
    - left "use slip" unchecked
    - left "use software compression" checked
    - left "use IP header compression" checked
    - left "use server-assigned addresses" checked (should I check "use specific server addresses" instead? If so, what?)

    On my home PC: (with Win XP Pro)
    - I have not set up a static internal IP address, but the dynamic one has not changed for months. Should I set up a static IP?
    - To set up the VPN connection, I launched "new connection wizard" and selected "Set up an advanced connection," "allow incoming connections," left everything checked in "devices for new connection" (Agere Systems PCI Soft Modem, bluetooth modem and and direct parrallel LPT1), clicked "allow virtual private connections," left all of the user permissions checked including the one I intend to use "administrator," left everything checked under "networking software." Then I clicked "finish" and the new connection appears in the "network connections" list under "incoming."

    When I tell my PPC to connect to the VPN, it dials and says "Connecting to (my home PC's external IP address)," but it fails and gives a pop-up that says "Cannot connect ... VPN server problems. Verify your username and password, and try again. If the problem continues, turn the device off and try again."

    When I have port forwarding enabled, my router log does record an incoming connection to port 1723 (the port I forward to for TCP).

    I have tried disabling the router firewall and enabling DMZ. I have Norton firewall disabled and am not running the Windows firewall or any other.

    Do I need to set up certificates for a PPTP connection?

    Does anyone see anything that I am doing wrong or might have missed?

    I would be eternally grateful for a solution.

  11. #11
    Registered User supercluver's Avatar
    Join Date
    01-18-2006
    Location
    Sugar Land, TX
    Posts
    53
    left everything checked in "devices for new connection" (Agere Systems PCI Soft Modem, bluetooth modem and and direct parrallel LPT1),
    I think this might be the reason. UN-check everything, as you aren't connecting to your PC through the modem, bluetooth, or direct connection but are tunneling through the internet.

  12. #12
    Registered User
    Join Date
    11-11-2005
    Location
    Westminster, MD
    Posts
    50
    My settings are exactly like searavens, except I have a static IP set and I don't have port 500 forwarded. I am confused about where Searaven is leaving "everything checked" for networking software, I don't even see this option under properties for my vpn connection on xp.
    Mine dials and connects fine (only takes 2 rotations of the arrows). I have tried resco and VM network client, neither recognize a network. Also, on my home pc, the vpn connection icon never shows a client connected. Recently, about 3 am one night while I was playing with it, it showed "1 client connected", but I still could not file browse. There were logs in my router from my PPC IP, where as normally I never see my verizon IP in the logs let alone coming through the 1723 port (even when 6600 shows connected to the vpn). Thanks for taking the time to help out btw.

    Quote Originally Posted by supercluver
    5harkology, perhaps a bit more info?? How are you trying to browse your shared folders?
    I share a folder on any of my computers on my home network. I connect to my VPN and then using Resco Explorer v5.21, I map a network drive.

    For example, I have the "My Documents" folder shared on my XP box that is also my VPN server. Under its permissions, everyone can access and modify it and its contents. Only myself and my wife can connect to my VPN server however. After I connect to my VPN on my 6600, I can map that folder in Resco File Explorer and browse its contents. That is how I do it.

  13. #13
    Registered User
    Join Date
    12-15-2005
    Location
    Out West
    Posts
    198
    Quote Originally Posted by supercluver
    I think this might be the reason. UN-check everything, as you aren't connecting to your PC through the modem, bluetooth, or direct connection but are tunneling through the internet.
    Thanks, but I tried un-checking them, and it didn't help.

  14. #14
    Registered User supercluver's Avatar
    Join Date
    01-18-2006
    Location
    Sugar Land, TX
    Posts
    53

    Check this out for me.....

    Okay both 5harkology and SeaRaven,

    Go to your Network Connections and right click on incoming connections and select properties. Then make sure TCP/IP, File and Print Sharing, and Client are all checked. Then select TCP/IP and click properties. Make sure "Allow callers to access my local area network" is checked, and then chose to specify the range of TCP/IP address. If you use the automatically assigned by DHCP addresses, it will give your PPC an IP of something like 169.254.xxx.xxx I believe. And probably with your router you are using something like 192.168.1.xxx so specify the range so that you get an IP that will work on your local network. Then see if this helps.

    Sorry, but I am away from my home computer right now. I will keep trying to think of what could be wrong....

  15. #15
    Registered User
    Join Date
    12-15-2005
    Location
    Out West
    Posts
    198
    Quote Originally Posted by supercluver
    Okay both 5harkology and SeaRaven,

    Go to your Network Connections and right click on incoming connections and select properties. Then make sure TCP/IP, File and Print Sharing, and Client are all checked. Then select TCP/IP and click properties. Make sure "Allow callers to access my local area network" is checked, and then chose to specify the range of TCP/IP address. If you use the automatically assigned by DHCP addresses, it will give your PPC an IP of something like 169.254.xxx.xxx I believe. And probably with your router you are using something like 192.168.1.xxx so specify the range so that you get an IP that will work on your local network. Then see if this helps.

    Sorry, but I am away from my home computer right now. I will keep trying to think of what could be wrong....
    Thanks, but I'm unclear on what range I would enter. Would I make the range, say, 192.168.1.1 to 192.168.1.200? How does the 169.254.xxx.xxx figure in to the range that I would enter?

  16. #16
    Registered User supercluver's Avatar
    Join Date
    01-18-2006
    Location
    Sugar Land, TX
    Posts
    53
    Quote Originally Posted by SeaRaven
    Thanks, but I'm unclear on what range I would enter. Would I make the range, say, 192.168.1.1 to 192.168.1.200? How does the 169.254.xxx.xxx figure in to the range that I would enter?
    Okay, the 169.254.xxx.xxx is what your VPN-Server would give to your PPC if you left it on DHCP assigned IP addresses, I believe. What I'm saying is to choose the range that it will assign. You should have set up your router to assign a range of IP addresses, I would think. Mine, for example, is 192.168.1.2 to 192.168.1.50. I have 2 computers that are on it consistently, my home box and my laptop, so I gave them 192.168.1.2 and 192.168.1.3 so they always have those. The rest are open. So I made my range 192.168.1.4 to 192.168.1.50. You should try something similar. I'm not sure if this is the issue you are having, but I know it works for me so its worth a shot.

  17. #17
    Registered User
    Join Date
    12-15-2005
    Location
    Out West
    Posts
    198
    Quote Originally Posted by supercluver
    Okay, the 169.254.xxx.xxx is what your VPN-Server would give to your PPC if you left it on DHCP assigned IP addresses, I believe. What I'm saying is to choose the range that it will assign. You should have set up your router to assign a range of IP addresses, I would think. Mine, for example, is 192.168.1.2 to 192.168.1.50. I have 2 computers that are on it consistently, my home box and my laptop, so I gave them 192.168.1.2 and 192.168.1.3 so they always have those. The rest are open. So I made my range 192.168.1.4 to 192.168.1.50. You should try something similar. I'm not sure if this is the issue you are having, but I know it works for me so its worth a shot.
    Still no dice.

    By the way, have have tried several times to bypass the router by sending the ethernet cable from my DSL modem directly into the PC. But when I do that, there is no Internet connection at all. As evidence that I know little about networking, I don't know why that didn't work. ... Could there be a problem with my modem?

  18. #18
    Registered User supercluver's Avatar
    Join Date
    01-18-2006
    Location
    Sugar Land, TX
    Posts
    53
    Quote Originally Posted by SeaRaven
    Still no dice.

    By the way, have have tried several times to bypass the router by sending the ethernet cable from my DSL modem directly into the PC. But when I do that, there is no Internet connection at all. As evidence that I know little about networking, I don't know why that didn't work. ... Could there be a problem with my modem?
    Well, okay try this for me. After you plug the ethernet cable directly into your pc, open a command prompt and type "ipconfig /renew" of course without the quotes and then type "ipconfig /all" and see what your IP address is. It shouldn't be the one from your router anymore but should be the one that you've been using on your PPC to connect to the VPN. After you've done this, try to connect to the VPN.

  19. #19
    Registered User
    Join Date
    12-15-2005
    Location
    Out West
    Posts
    198
    Whe I do ipconfig/renew, I get:

    "The operation failed as no adapter is in the state permissible for this operation" in the command window.

  20. #20
    Registered User supercluver's Avatar
    Join Date
    01-18-2006
    Location
    Sugar Land, TX
    Posts
    53
    Then type "ipconfig /all" and see what your IP and such is... It should be your externally viewable IP address that you get from your DSL provider. If not, you need to check your TCP/IP settings for your network adapter and see whats up.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts