+ Reply to Thread
Results 1 to 3 of 3
  1. #1
    I'm a total loser and I've been banned!!!
    Join Date
    04-28-2004
    Location
    Elsewhere
    Posts
    2,758

    Linux 6600 tethering help needed (outbound)

    There are great articles out there (via google) on how to tether your 6600 to use the PC's bt as an access point to the PC's Internet connection.

    What I want to do is have the PC use bt to talk to the phone's CDMA connection (ExpresNetwork/Vision).

    What I've done is use the steps from the first article... up till the end, where instead of using pand --listen, I use wvdial with a profile set to use /dev/rfcomm0. Unfortunately wvdial says the modem is not responding.

    I can verify this because doing minicon /dev/rfcomm0 or using kermit and set line /dev/rfcomm0 it all seems to work great (pairing, pins, no errors, seems to be sitting there letting me type) *BUT* I can't get the modem to respond to AT or even ATE1Q0 or ATQ0.

    Without making any changes, I can move the USB dongle to a W2K laptop, and tether it just fine. This means something I'm doing on the Linux laptop is wrong... but I have no guide on what to do, just some guessing.

    Help?

    Ehud
    PS I've perused Search on this site, as well as others, as well as google. The closest I found was an article on IR tethering, which is where I got the info that I tacked on on the end of phone-->pc bt tethering.

  2. #2
    Registered User
    Join Date
    10-08-2005
    Location
    NYC
    Posts
    8
    Hi Ehud,

    Does wvdial specifically let you control what speed it is accessing the device at? Sounds like it might be a speed problem.

    Also, you know about WModem default loading set up to reply with number responses instead of the regular default AT command set responses (we set this back with an ATV1), and you probably aren't seeing a '0' or a '4' so i won't bother mentioning it .

  3. #3
    I'm a total loser and I've been banned!!!
    Join Date
    04-28-2004
    Location
    Elsewhere
    Posts
    2,758
    I did kermit set speed 19200 and it still didn't get me a response.
    ate1q0 but didn't try v1. I'm gathering you're thinking I already
    eliminated that option by not seeing a numeric response... but I'll
    try it.

    Good idea... other suggestions welcome. I'd try it now, but I got
    a date over...

    E

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts