+ Reply to Thread
Results 1 to 2 of 2
  1. #1
    Registered User
    Join Date
    01-06-2005
    Location
    Minnesota
    Posts
    2

    Samsung I700 as a CDMA Modem working in Linux!

    It took a little play, but I finally managed to tether and operate my sph-i700 successfully as a CDMA modem through linux.
    No more XP and “special drivers” necessary!

    My distribution is Slackware 9, phone s/w windows mobile 2003.
    I’m using a third party minisync cable from boxwave. Here is the process that worked for me, Using information gleaned from a number of different informative sites:

    Power up and connect your i700 via the sync cable.

    There are three types of USB controllers usually found in computers, the uhci, the ohci and the ehci. They have the corresponding kernel modules, uhci.o, ohci.o and ehci-hid.o. Load the correct module for your system. eg for uhci, type (as root)

    modprobe uhci

    ( Mine happened to be active by default in the distro )

    The i700 conforms to the Universal Serial Bus Communication Device Class Abstract Control Model (USB CDC ACM) specification, So activate acm.o with:

    modprobe acm

    Note that for the i700 you do NOT need to modprobe usbserial
    or ftdi_sio.

    /var/log/messages should now contain the following:

    hub.c: new USB device 00:07.2-1, assigned address 2
    usb.c: USB device 2 (vend/prod 0x4e8/0x6601) is not claimed by any active driver
    usb.c: registered new driver acm
    ttyACM0: USB ACM device
    acm.c: v0.21:USB Abstract Control Model driver for USB modems and ISDN adapters

    Don’t let the “not claimed by any active driver” throw you… keep moving on.

    Next – You’ll notice that the i700 was established by acm as ttyACM0. Great!
    However, take a look under /dev filesystem and ttyACM0 is nowhere to be found.
    What to do?

    "Make node" will create a device entry that does not already exist. Make sure to run it as root

    mknod ttyACM0 c 166 0

    Make sure you have read and write permissions globally

    chmod go+w /dev/ttyACM0

    (go+w = add write permissions to group members and other/everybody)

    Now, symlink your new virtual device to modem ( optional )

    cd /dev/

    ln –s /dev/ttyACM0 /dev/modem


    At this point, it was easiest for me to create the necessary ppd files with the pre-existing “helper” script included with slackware

    pppsetup

    I chose:

    atdt#777 as the phone number of ISP

    /dev/modem as /dev/ttyS

    230400 as baud rate

    ( this speed worked for me, but you may want to trying starting out with 115200 )

    No callback

    Default init string

    Vzw3g.com as ISP domain name

    Nameserver as 66.174.6.7
    Secondary as 66.174.3.7

    (it's prob. better to add usepeerdns to the options file manually tho )

    PAP Authentication

    yourcellnumber@vzw3g.com

    password vzw

    Now, go to /etc/ppp and edit your options file.
    It should read like this:

    lock
    defaultroute
    noipdefault
    usepeerdns (add this line manually)
    modem
    /dev/modem
    230400
    crtscts
    noauth (uncomment this )
    passive
    asyncmap 0
    name yourphonenumber@vzw3g.com

    Now, you should be able to issue command

    ppp-on


    That’s it! If all goes well, you should see the connection link up with something like

    Serial connection established.
    Using interface ppp0
    Connect: ppp0 <--> /dev/modem
    Local IP address 69.78.XXX.XXX
    Remote IP address 66.174.216.13
    Primary DNS address 66.174.6.7
    Secondary DNS address 66.174.3.7
    Local: 69.78.XXX.XXX -> Remote: 66.174.216.13 ppp0

    Press enter and test things out with a ping to your favorite IP.

    Disconnect the link at any time with the command

    ppp-off

    As far as I’m aware, operating the i700 as a tethered modem under any operating system is officially unsupported by Verizon. Also, according to the manual, use of any 3rd party hardware instantly violates your warranty. So – use this proceedure at your own risk. I haven’t had any issues with these steps, but your mileage may of course, vary.

    Good luck, and happy networking! ( Look ma – no wires! )

    Fireshade

  2. #2
    Registered User equus's Avatar
    Join Date
    10-06-2003
    Location
    Milpitas. California
    Posts
    5,293
    I am moving this over to FAQ section. It was some good detective work on your part to get it going. Now all the Linux gurus can be happy!!!!. thank you once again for the hardwork and it is members like you that make this a real neat place to hang out!!!!! Cyber Cafe is alive !!!!!!!
    Funny it worked.....the last time! Now I am not sure what was working before they put a hole in my head !

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts