+ Reply to Thread
Results 1 to 8 of 8
  1. #1
    Registered User
    Join Date
    01-10-2008
    Posts
    42

    My i760 not recognizing my microsd card

    I just bought a Kingston 2GB MicroSD card. I formatted it with my PC and inserted into the i760 and it's not reading it at all.

    I also just tried a 4GB card with the hack and it did not read the card as well.

    What should I do? Thanks.

  2. #2
    Registered User
    Join Date
    10-02-2005
    Posts
    147
    search for "SDHC.cab"

  3. #3
    Registered User
    Join Date
    01-10-2008
    Posts
    42
    As I said I've already tried it with the hack. Anyway I returned 4gb sdhc card and got the 2gb card so I shouldn't have to worry about the hack (I uninstalled it).

    My device is still not recognizing my 2gb microsd card.

  4. #4
    Registered User
    Join Date
    04-08-2007
    Posts
    177
    Have you tried a hard reset??? I know it sucks but unfortunately this might be your only fix. I just bought a 2gb MicroSD card and it works fine. I also made sure that I formated the card using the device and not my computer.

    If you can't format the card using your computer, I would recommend a hard reset, then format the card using your device. It could be possible that you messed things up on the device when you did the hack!!!

  5. #5
    Registered User
    Join Date
    06-28-2007
    Posts
    428
    Formatting cards has seemed to cause problems for others. I'm not sure there is any reason to do that. (I didn't). Maybe try to reformat, and make sure to do it in FAT32 (I think - you might want to search for "format").

  6. #6
    Registered User
    Join Date
    01-10-2008
    Posts
    42
    I tried my friend's card around when I first got the phone and it worked fine.

    So I bought my own card and inserted it into my laptop first. It wouldn't let me open it without formatting it first, so that's what I did (FAT32).

    I don't want to hard reset!

  7. #7
    Registered User
    Join Date
    01-10-2008
    Posts
    42
    Any other inputs before I do the dreaded hard reset?

  8. #8
    Registered User
    Join Date
    01-10-2008
    Posts
    42
    Well I did the hard reset and used the same card and my phone STILL doesn't recognize it. I tried formatting it with FAT32, same result.

    THEN I tried my friend's 2gb card (the one I first tried when I got my phone), and it worked!

    Why does his work and not mine? I have tried two different brand new cards and they haven't worked. The only difference is that BEFORE I inserted the cards in the phone, I formatted them on my PC first. I probably shouldn't have formatted them.

    But if that's the problem, how do I UNformat them, if there is such a thing. In other words, how do I bring it back to the state it's in when I first buy it?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts