+ Reply to Thread
Results 1 to 12 of 12
  1. #1
    Registered User
    Join Date
    03-17-2009
    Posts
    6

    IE won't connect through WiFi

    I just purchased an i760 and love it so far.
    The only problem I am having is connecting to the Internet through my WiFi connection at home.
    I get connected to my wireless router. The i760 says it's connected to my wifi router when I turn on the wifi radio in the i760.
    But when I open IE on the i760 it won't load any internet pages.
    Is there something else I need to set?
    I know my router is working cause my laptop gets to the internet through the same wireless router.
    Under Configure Wireless Network I have the following:
    "Connect to:" set to " The Internet"
    "Authentication" is set to "Open"
    "Data Encryption:" is set to "WEP"
    I did not check "The key is automatically provided"
    I put in my "Network key"
    "Key index:" is set to "1"
    I did not check "Use IEEE802.1x network access control

    Under "Network Adapters" I have the following:
    "My network card connects to:" is set to "The Internet"

    Under the "SAMSUNG b/g WiFi CARD" I have the following:
    For "IP Address" I picked the "Use server-assigned IP address" option.
    Under "Name Servers" there are no entries at all for "DNS", "Alt DNS", "WINS" or "Alt WINS"

    Are those settings correct?

    If so, what else could be wrong?

    Thanks for any help.

  2. #2
    Registered User
    Join Date
    03-06-2009
    Posts
    57
    It would seem to me that you have a local connection but no IP address. This would happen if you do not have enough DHCP leases or if you lock down your router by requiring a filter for the allowed MAC addresses. These are not the only router issues that could be at play, but they are two likely ones.

  3. #3
    Registered User
    Join Date
    03-17-2009
    Posts
    6
    Quote Originally Posted by gkamieneski View Post
    It would seem to me that you have a local connection but no IP address. This would happen if you do not have enough DHCP leases or if you lock down your router by requiring a filter for the allowed MAC addresses. These are not the only router issues that could be at play, but they are two likely ones.
    Thanks for the reply.
    How do I check and fix the items you mention above?
    How do I check my number of DHCP leases? Could I have to many devices trying to access the internet through my router? I have one desktop hardwired to the router plus another desktop and a laptop accessing the router via wireless connection. Plus my iPod Touch and my stepson's iPod Touch both have no problem accessing the internet through the same wireless connection.
    Should I try disconnecting one or more of those other wireless connections and see if it works?

    I do know that when the i760 is connected to my router an IP address does show up under Network Adapters for the SAMSUNG b/g WIFI CARD.
    Should that be the router's IP address or something different?

  4. #4
    Registered User
    Join Date
    03-06-2009
    Posts
    57
    If you don't recall locking down your router in the first place, then it is probably not the problem. The router's configuration program gives you the opportunity to enhance security by limiting the number of dhcp leases provided and you can even limit access to explicit MAC addresses of wireless adapters. attempting to connect.

    It sounds to me that you don't have the security dialed-up, so it is more likely that the Samsung WiFi card is not negotiating correctly with your router. It would help to look in the router program and see what wireless devices are connected.

  5. #5
    Registered User
    Join Date
    03-17-2009
    Posts
    6
    Quote Originally Posted by gkamieneski View Post
    If you don't recall locking down your router in the first place, then it is probably not the problem. The router's configuration program gives you the opportunity to enhance security by limiting the number of dhcp leases provided and you can even limit access to explicit MAC addresses of wireless adapters. attempting to connect.

    It sounds to me that you don't have the security dialed-up, so it is more likely that the Samsung WiFi card is not negotiating correctly with your router. It would help to look in the router program and see what wireless devices are connected.
    This is ridiculous. This is why the iPod Touch is so popular. It hooks up to my wifi system and gets to the internet without any hassle. You get a fancy device running Windows Mobile and it's a giant headache.

    I am looking at my router software now. The router is assigning an IP address to the i760 and I see that same IP address on the i760 in the SAMSUNG b/g WIFI Card settings.
    Why won't it get to the internet? This is so frustrating!
    I use Verizon DSL for my ISP. Since my ISP is DSL the router is set to use PPPoE in the WAN settings. Can that be the problem?
    On the i760 on the "Name Servers" tab of the SAMSUNG b/g WIFI Card settings, there are no entries for the DNS, Alt. DNS, WINS or Alt. WINS. Should there be settings there?
    It says Name server addresses may be automatically assigned if DHCP is enabled on the adapter which it is in my router. Should I see entries for the "Name Servers" on the i760? If so why are they not being assigned?

  6. #6
    Registered User
    Join Date
    03-06-2009
    Posts
    57
    I don't see anything wrong in your reporting. If you can, let us know what IP address your phone is pulling. It would be an inside the house IP not that which you are known by on the internet. Should be something like 192.168.1.x.

    Not really fair to blame WM for this. Many WiFi adapters take a little work before they are able to access the internet, regardless of the OS.

  7. #7
    Registered User
    Join Date
    03-17-2009
    Posts
    6
    Quote Originally Posted by gkamieneski View Post
    I don't see anything wrong in your reporting. If you can, let us know what IP address your phone is pulling. It would be an inside the house IP not that which you are known by on the internet. Should be something like 192.168.1.x.
    The IP address being assigned to my i760 is:
    192.168.0.106

    Does that help at all with figuring out my problem?

  8. #8
    Registered User
    Join Date
    03-06-2009
    Posts
    57
    That sounds like a valid IP for your network and as long as your cable modem is connecting to the internet, you should be able to browse with IE. All I can think of now is a proxy server problem. Try changing the settings from Work to My ISP and see if skipping the proxy makes a difference.

  9. #9
    Registered User
    Join Date
    03-17-2009
    Posts
    6
    Quote Originally Posted by gkamieneski View Post
    That sounds like a valid IP for your network and as long as your cable modem is connecting to the internet, you should be able to browse with IE. All I can think of now is a proxy server problem. Try changing the settings from Work to My ISP and see if skipping the proxy makes a difference.
    On what device and where do I change the settings from Work to My ISP?
    Do you mean on the i760?
    If so, is that under "Configure Wireless Networks" or "Configure Network Adapters"?
    If it is under "Configure Network Adapters", I already have the item, "My network card connects to:" set to "The Internet".
    Likewise if it is under, "Configure Wireless Networks", where it lists my "Network name" and the next item is "Connects to:", that to is already set to "The Internet".
    Should I try changing either one, or both of those to "Work"?

    By the way, thanks for all your help so far.

  10. #10
    Registered User
    Join Date
    03-06-2009
    Posts
    57
    I believe you've proven you are correctly connecting to your router by virtue of the IP address that you are pulling through DHCP. You should be able to ping your gateway (probably 192.168.1.1) and connect to other network devices inside your home.

    Has to be a proxy server setting causes your issues going outside your home. Some things to check:

    Settings/Connection look at Proxy setup and see that there's a check in the box for this network connects to the internet. Then look at the advanced tab, select networks then network management. See what the setting is for both connections, My Work Network or My ISP. Try changing these settings and see what results. I believe when they are set to My Work Network that you are choosing to use a proxy server and this may not be what you want happening.

    Sorry, but I'm starting to shoot blanks with this one. No argument here that the Ipod Touch handles connectivity with hardly any issues but that's almost true of everything Apple over Winop.

  11. #11
    Registered User
    Join Date
    03-17-2009
    Posts
    6
    Quote Originally Posted by gkamieneski View Post
    I believe you've proven you are correctly connecting to your router by virtue of the IP address that you are pulling through DHCP. You should be able to ping your gateway (probably 192.168.1.1) and connect to other network devices inside your home.

    Has to be a proxy server setting causes your issues going outside your home. Some things to check:

    Settings/Connection look at Proxy setup and see that there's a check in the box for this network connects to the internet. Then look at the advanced tab, select networks then network management. See what the setting is for both connections, My Work Network or My ISP. Try changing these settings and see what results. I believe when they are set to My Work Network that you are choosing to use a proxy server and this may not be what you want happening.

    Sorry, but I'm starting to shoot blanks with this one. No argument here that the Ipod Touch handles connectivity with hardly any issues but that's almost true of everything Apple over Winop.
    Aren't the settings you mention above related to when you dial in on Verizon's network? Why would they matter on a wifi connection? I have tried playing with them but will try again.
    Although in the Proxy settings when I put a check in the box for this network connects to the internet, when I hit OK and then go back in, it is no longer checked? Why would that happen?

    Do you think my problems connecting at home can be related to the age of my wifi router? It's an older dlink that supports only wifi B. Over this weekend I was at two locations that had unsecured wifi access and my i760 attached to those and got out to the internet without any problem. Could the i760 Samsung b/g wifi card just be having trouble negotiating out through the old router I have?

  12. #12
    Registered User
    Join Date
    03-06-2009
    Posts
    57
    My settings are set up to use "My Work Network" because I do not want apps using VZW broadband. When I go into the Proxy tab, it says "My Work Network" on the top of the page and the box is checked for this network connects to the internet.

    You may want to go through this procedure again and then do a soft boot to see if you can get those settings to stick. As I said, you're pulling an inside IP from your router. I'll bet you could sit at a PC, go to a command prompt and ping or tracert to your smartphone's IP. I really don't think it's an issue with the age of your router. There is plenty of 802.11b equipment still in use out there.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts