+ Reply to Thread
Page 1 of 2 1 2 LastLast
Results 1 to 20 of 22
  1. #1
    Registered User
    Join Date
    09-02-2004
    Posts
    220

    Hack to speed up Comcast POP3 Login Works...

    I am an i730 upgrader. I thought this hack may be a useful post here for new i760 owners. This is a registry hack from the i730 forum that I can confirm works on the i760.

    As posted in the i730 forum:

    Ok folks here is a little tidbit of information. If you use your smtp comcast account with your device you undoubtedly have a VERY slow login. Mine was on the order of about 2 minutes to just login.

    It turns out that the issue lies with the Comcast server. The short answer is that the Comcast server does not have SSL enabled and the mobile operating system (2003, WM5) thinks it does. Then there comes a conflict and a mobius loop of sorts.

    Anyway I found the fix on another site.

    Here are the directions:

    Follow these steps using any register editor software for Pocket PC. (I used PHM)

    1. Open Registry editor.
    2. Locate HKEY_LOCAL_MACHINE\Software\Microsoft\Inbox
    3. Create a new DWORD value "ForceOffSSL" and give it a value of 1, Base=Decimal (tap Edit, and New DWORD Value).
    4. Soft-reset device.
    5. For Comcast server make sure your settings have no ":975" or any other number after the SMTP settings.

    I found that the PHM Editor did not set up in my i730 flawlessly and I had to manually open the .cab file titled "regedit.Mrln_ARM" for the i730.

    Hope this helps at least the Comcast users.
    i760 (i730 upgrader)

  2. #2
    Registered User
    Join Date
    11-04-2007
    Posts
    12
    Works GREAT! THANK YOU! My god it used to be painlessly S L O W...

    As jfourman said, remove any .965 or .975 numbers in your incoming/outgoing mail server setup to simply be:

    Incoming: mail.comcast.net
    Outgoing: smtp.comcast.net

    ALSO, dont forget to UNCHECK "Incoming Mail server requires SSL authentication" under options.

    Works so fast now!

    Thanks to jfourman for posting this!!

  3. #3
    Registered User
    Join Date
    10-29-2007
    Posts
    8
    Isn't wireless e-mail without SSL (at public hotspots) insecure?

  4. #4
    Registered User
    Join Date
    09-02-2004
    Posts
    220

    Not enabled by Comcast

    The hack doesn't change the security of the email. SSL is not enabled on the server end at Comcast. So regardless of the i760 setting, the email is not SSL encrypted. The hack simply keeps the i760 from expecting SSL from Comcast when it doesn't exist.
    i760 (i730 upgrader)

  5. #5
    Registered User
    Join Date
    06-24-2006
    Location
    IL
    Posts
    2,290
    The problem is, I think you've just disabled SSL for all your mail accounts. So for those that do support it, you've lost the security it provides because you're now in clear text mode.

    Since you can turn this on or off for individual accounts, I'm not sure why this is helping - just don't check the box requiring SSL for that account.

  6. #6
    Registered User
    Join Date
    09-02-2004
    Posts
    220

    Maybe

    The hack may disable SSL for all email accounts. I have two...I have a Lotus Notes account that gets email via mNotes which is a PPC app which is still SSL Secured since it uses it's own instructions/registry to connect to the host Notes Server and Comcast which is not SSL Secure in the first place.

    Unchecking the SSL required box doesn't help with Comcast. This was a known issue on the i730 and remains on the i760. All Comcast users deal with horribly long "login" wait times until this hack is installed.
    i760 (i730 upgrader)

  7. #7
    Registered User
    Join Date
    11-03-2007
    Posts
    28
    You lost me right here...

    "and give it a value of 1, Base=Decimal (tap Edit, and New DWORD Value)"

    what do I type in Value?

  8. #8
    Registered User
    Join Date
    09-02-2004
    Posts
    220

    DWORD Data = 1 Decimal

    md727: I use Resco Registry Editor. I created a new DWORD. The editor screen has 3 entry fields:

    Name = ForceOffSSL
    DWORD Data = 1
    Base (radio button) = Dec (the other radio button choice is Hex)

    The registry entry then looks like: ForceOffSSL 0x1 (1)

    Hope this helps
    i760 (i730 upgrader)

  9. #9
    Registered User
    Join Date
    10-29-2007
    Posts
    8
    Its rather disturbing if Comcast does not support SSL for wireless e-mail. From the Comcast FAQ "How to configure Outlook 2003 to send and receive E-mail while traveling":

    6. On the Advanced tab, enter 465 in the Outgoing mail (SMTP) port number field and 995 in the Incoming mail (POP3) field. For both, click This server requires a secure connection (SSL).
    Are they really not supporting SSL?

  10. #10
    Registered User Sleeve's Avatar
    Join Date
    05-21-2003
    Location
    Between my shoes and my hat
    Posts
    1,703
    Why would it matter to encrypt the last leg of the email's journey to you when it traveled most of its life in clear text?
    -s

  11. #11
    Registered User
    Join Date
    10-29-2007
    Posts
    8

    SS?

    Quote Originally Posted by Sleeve View Post
    Why would it matter to encrypt the last leg of the email's journey to you when it traveled most of its life in clear text?
    I think the idea is that an e-mail to your bank, for example, should be encryped while it's on a public wireless network.

  12. #12
    Registered User Sleeve's Avatar
    Join Date
    05-21-2003
    Location
    Between my shoes and my hat
    Posts
    1,703
    It won't be from the point it leaves Comcast's servers onward. Then it is actually easier to sniff than an EVDO data connection.

    Never send anything private in email, it is not a secure transport unless you use S/MIME certificates.
    -s

  13. #13
    Registered User
    Join Date
    10-29-2007
    Posts
    8
    I see what you are saying about the EVDO connection: I was thinking about the case where I use public wi-fi instead of EVDO; the unencrypted wi-fi connection is probably the least secure.
    Anyway, my real question was whether Comcast is telling the truth in their FAQ answer I referenced earlier. They strongly recommen SSL when using wireless - is the recomendation pointless, since they are not providing an SSL connection, even if you request one in your email account setup?

  14. #14
    Registered User
    Join Date
    06-24-2006
    Location
    IL
    Posts
    2,290
    It's not a matter of the e-mail contents - it's a matter of the user ID and password. Without SSL on, those are sent in the clear, and I'd prefer to never do that.

  15. #15
    Registered User
    Join Date
    11-17-2006
    Posts
    56
    I have been using this hack on my Treo 700wx but now that I have the i-760 it has stopped working for me. Has anyone else experienced this? Is it working for everyone else?

  16. #16
    Enterprise Data Architect Mark_A_K's Avatar
    Join Date
    11-27-2003
    Location
    CT
    Posts
    5,384
    Has anyone approached Comcast with this issue?

  17. #17
    Registered User
    Join Date
    09-02-2004
    Posts
    220
    A couple of days ago, I began getting an SSL Cert error when trying to send emails to my Comcast account. I removed the hack which stopped the error; but slowed the connect down again.

    I wonder if Comcast has now added SSL.
    i760 (i730 upgrader)

  18. #18
    Registered User
    Join Date
    06-24-2006
    Location
    IL
    Posts
    2,290
    I don't know that they've "added" it. What's probably happened was a configuration change that required it for folks getting mail from outside of their network.

  19. #19
    Registered User
    Join Date
    02-06-2008
    Posts
    18
    I cant get my comcast email to work at all. I get a 'error synchronizing' message after a horribly long wait time for it to 'logging on'

    Any ideas?

  20. #20
    Registered User
    Join Date
    12-15-2007
    Posts
    6
    I get this same message intermittently. It seems that I get it more frequently as my comcast online mail box gets fuller, but I may be imagining things. How long has this been going on for you? Did it used to work and then stopped?

    I also have the issue with incredibly long login times.

    I keep hoping someone will crack the code on this...

    -Mark

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts