+ Reply to Thread
Results 1 to 10 of 10
  1. #1
    Registered User
    Join Date
    04-27-2005
    Posts
    137

    Disable Notify.wav when plugging in charger?

    Every time I plug the charger into my phone, the Notify.wav sound from the \Windows folder (in ROM) plays. Sometimes twice. Annoying!

    I've emptied every sound related registry entry I could find that referenced "notify", though some of them probably referred to the notify.wma file (also in \Windows). Anyway....the dang sound still plays. Does anyone know how to stop that from happening?

  2. #2
    Registered User
    Join Date
    09-20-2007
    Posts
    97
    There's one way but probably not the way you're looking for.

    Start->Settings->Sounds&Notifications->Uncheck Programs.

    Unfortunately this will turn off all notification sounds including alarms.

    The even less fun way, but will probably yield the desired result:

    Regedit:
    HKCU\ControlPanel\Notifications\

    Explore any folder that looks like {xxxxxxxx-xxxx-xxxxxxxxxxxx}

    and the string value Wave = notify

    Change notify to *none*

    Save changes and soft reset. Plug in power cord and see if it beeps. If it doesn't beep, you have changed the correct registry setting. If not, restore the previous setting and try another folder that looks like {xxxxxxxx-xxxx-xxxxxxxxxxxx}. Repeat until you find the correct one.
    Last edited by KINetics; 11-12-2007 at 01:47 AM.

  3. #3
    Registered User GadgetNut's Avatar
    Join Date
    03-19-2005
    Location
    Philly Burbs
    Posts
    228
    Yeah - what's up with the double notification when you plug in? Not a big deal - just curious.

    Jay
    If it ain't broke. . . break it!!

  4. #4
    Registered User
    Join Date
    02-09-2007
    Location
    Hampton Roads (SE Virginia)
    Posts
    241
    Quote Originally Posted by GadgetNut View Post
    Yeah - what's up with the double notification when you plug in? Not a big deal - just curious.

    Jay
    My guess is that the "double" notification is a result of a loose charger connection; so you get an initial notification when you first plug in, and then another when you set the phone down, for example (it doesn't happen every time, for me).

    There's another thread that talks about the loose charger connector. Though I haven't had problems with phone not charging, I have noticed that I can trigger the notification twice, sometimes.

  5. #5
    Registered User
    Join Date
    04-27-2005
    Posts
    137
    Quote Originally Posted by KINetics View Post
    There's one way but probably not the way you're looking for.

    Start->Settings->Sounds&Notifications->Uncheck Programs.

    Unfortunately this will turn off all notification sounds including alarms.

    The even less fun way, but will probably yield the desired result:

    Regedit:
    HKCU\ControlPanel\Notifications\

    Explore any folder that looks like {xxxxxxxx-xxxx-xxxxxxxxxxxx}

    and the string value Wave = notify

    Change notify to *none*

    Save changes and soft reset. Plug in power cord and see if it beeps. If it doesn't beep, you have changed the correct registry setting. If not, restore the previous setting and try another folder that looks like {xxxxxxxx-xxxx-xxxxxxxxxxxx}. Repeat until you find the correct one.

    Thx for taking the time to post that! I had already edited all those registry entries by emptying them, for ALL occurences of "notify" . I now entered *none* instead, end did a soft reset. But no lock...still gave me the alert when I plugged in the charger...

  6. #6
    Registered User
    Join Date
    09-20-2007
    Posts
    97
    Hmm, there's one last way I can think of.

    On your computer open up notepad, then save the blank file as notify.wav or notify.wma, whatever your i760 is using for the plugin sound. That will basically give you a 0kb file. Then upload the file into your Windows directory overwriting the original notify.wav file. You might need to use Resco File Explorer as the default File Explorer might not let you overwrite protected files.

    That way, when you plug in the phone, the i760 will play the dummy notify.wav sound and thus no sound.

  7. #7
    Registered User
    Join Date
    04-27-2005
    Posts
    137
    I tried something similar...I tried to rename the Notify.wav file, but it would not let me because it is in ROM. When I try to copy the file to \Windows, it won't actually let me...simply never "finishes"...

  8. #8
    Registered User
    Join Date
    09-20-2007
    Posts
    97
    Did you try using Resco Explorer? I just did it and it overwrote it just fine. Won't have access to my power cord until I get back later today so I can't tell if it disabled the sound, but at least the file was modified.

    Neither activesync nor WDMC will let you overwrite/delete ROM files.

    Edit: Just got home and plugged it in and sure enough, no more alert sound. Looks like we have a solution.
    Last edited by KINetics; 11-12-2007 at 05:24 PM.

  9. #9
    Registered User
    Join Date
    11-26-2007
    Posts
    2
    Awesome! That sound was definitely annoying, and really loud. I found I didn't need to use resco, I just copied it straight into \windows from activesync's explore window.

  10. #10
    Registered User mcharron's Avatar
    Join Date
    07-08-2005
    Location
    Running Springs, CA
    Posts
    159
    The reason you sometimes get the double notification is because the screen is off. It does it once for being plugged in and again when the screen comes on.
    mlc

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts