Long time lurker, first time poster...

I have researched and read all of the meaaging notification threads, but I don't see an answer to my specific question. I want to totally disable notification of text messages altogether. I went to Settings-->Sounds and Notifications-->Notifications and unchecked all boxes for New Text Message, but I still get a notification over the left softkey when a test message comes in. When I press the left softkey, a preview of that text message shows up on the screen. I would like for no notification to occur at all.

Any ideas? Do the threaded SMS apps resolve this at all?

Thanks!