+ Reply to Thread
Results 1 to 9 of 9
  1. #1
    Registered User
    Join Date
    11-10-2007
    Location
    NC
    Posts
    159

    wi-fi connection issue

    On my i760, I've set up wireless for my home network. I know the network settings (using WPA2-psk) are correct because I just went through an update to the firmware on the router and had to re-setup my network again.

    What happens is that when my security is disabled, the wi-fi connects fine. When I enable security, the i760 will search but eventually tell me it can't connect. So it has to be a setting somewhere that I've missed. But I've set everything I've found to set... appropriate security protocol selected, key entered... but no connection.

    Any suggestions?

  2. #2
    Registered User
    Join Date
    06-24-2006
    Location
    IL
    Posts
    2,290
    Are you allowing AES as an encryption type? If not, you might do that and change the settings on your phone to see what happens.

    If you're not broadcasting the SSID, you should also go into the network settings for the SSID and check the box that says "This is a hidden network."

  3. #3
    Registered User
    Join Date
    11-10-2007
    Location
    NC
    Posts
    159
    No, I used TKIP. I also did not have hidden network checked. What is this?

    I tried again with just checking hidden network. No joy.

    Tried again with both hidden network and AES selected with the proper key (but I think it should really be TKIP). No joy.

    Somehow I found the MAC address for my device (but can't find it now) and have my wireless router assiging a static IP to the i760.

    Still no luck with WPA2-PSK/TKIP (as set up on the wireless router).

  4. #4
    Registered User
    Join Date
    06-24-2006
    Location
    IL
    Posts
    2,290
    WM6 and TKIP alone don't seem to play nicely. Check your wireless router to see if it supports either AES or TKIP+AES. If it does, switch the encryption settings. My Linksys wouldn't let me TyTN II connect until I did that. Don't ask me why.

    The hidden network setting tells the PDA that the SSID isn't being broadcast - a very basic way to hide your AP from everyone that makes it a bit harder on script kiddies.

    If you try those settings and it still doesn't work, look for a firmware update for your wireless router. It's amazing the number of non-standard ways that folks implemented the 802.11 standards that they "fix" with firmware upgrades. Of course, if they'd done it right the first time...

  5. #5
    Registered User
    Join Date
    11-10-2007
    Location
    NC
    Posts
    159
    Interesting info about WM6 and TKIP. I'll change everything over to AES and try that.

    I duplicated the problem at a relative's house today that runs a Linksys WRT54G wireless router and WPA-PSK/TKIP. Or maybe it's WPA2... I set it up a while back and can't remember which it is. Anyway, could not connect.

    My router is a DLink DI-624 and I just installed the latest firmware on it this morning. (FW 2.76).

    I'll post back here my results.

    Edit:
    Last edited by speedlever; 11-22-2007 at 07:22 PM.

  6. #6
    cYGONE
    Join Date
    04-08-2007
    Location
    Boston
    Posts
    114
    Quote Originally Posted by speedlever View Post
    ...........

    What happens is that when my security is disabled, the wi-fi connects fine. When I enable security, the i760 will search but eventually tell me it can't connect. any suggestions?
    though i am hesitant to say this to tech-savvy people in this forum, i must say that if i were to take the above quote at 'face value' then my first suggestion to my client would be "you may have a pass-phrase problem."

  7. #7
    Registered User
    Join Date
    11-10-2007
    Location
    NC
    Posts
    159
    That would stand to reason. But I know the pass-phrase is correct. I set up 3 computers on the network this morning after putting new firmware on the router. I've verified the pp many times to no avail.

  8. #8
    Registered User
    Join Date
    11-10-2007
    Location
    NC
    Posts
    159
    Alrighty now... success!

    But I'm not sure what fixed it.

    I did several things at once:
    - Changed from TKIP to AES (which hadn't worked before)
    - Changed from connecting to the Internet - to Work
    - plugged in my key
    - navigated to the Network Adapter
    - changed My network card connects to -> Work
    - Selected Samsung b/g wifi card
    - Changed it to use a specific IP address (the static IP I have assigned in the router)... which I thought it would pick up in DHCP automagically.
    - Gave it a std subnet mask (255.255.255.0)
    - gave a default Gateway of 192.168.0.1

    Then it connected just fine. Just wish I knew which of the above fixed it!

  9. #9
    Registered User
    Join Date
    10-08-2008
    Posts
    1
    I think the last 4 changes fixed it, at least those are the steps I followed to get my phone to find the internet under a similar setup.

    Which brings me to my post, I have a fixed IP assigned to my b/g card which works great at home, but when I'm at public access points I have to delete those settings to get access to the public access point.

    Is there a way around this, or will I always need to remove these settings when traveling?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts