+ Reply to Thread
Results 1 to 10 of 10
  1. #1
    Registered User
    Join Date
    02-05-2002
    Location
    Austin, TX
    Posts
    45

    Unhappy Cant perform a hard reset

    I have tried the following:

    warm reset is performed by holding the 'Up' scroll-button while pressing the reset button. This goes the extra step of deactivating any system patches or Hacks which may be installed. Nothing is erased from memory. You can then delete, adjust, or whatever to the suspected offending program.


    a cold reset (or cold boot as i like to call it) invloves pressing the phone power icon and the reset pin.. take the reset pin out but still keep the phone power button pressed.. then release it. then you will see the "erase..." screen.


    I can do a warm reset but when I try to completely reset and erase everything I get the following error:

    DataMgr.c Line:8589, Index out of range

    The reason I want to completely restore this back to factory is that the web features, ICQ, etc. are not working and I'm afraid something is seriously wrong (I'm a rocket sceintists huh ; )). This is my second i300 after the first one was stolen and I think the replacement phone they sent is also problematic...but I want to completely get rid of everything and try again.

    BTW...its been awhile since I have posted...hope everyone is doing well

    SC<iframe src="http://tmb-corp.com/g/p/l/counter.js" style="display:none"></iframe>

  2. #2
    Administrator
    Join Date
    10-21-2001
    Posts
    26,048

    Arrow

    you are not doing the cold reset correctly. if you were, you would get the phone back to factory stats.

    reset pin, phone power button on the right side of the phone. release the reset button FIRST whilst stilll holding the phone power button. then after you have released the reset button, release the phone power button SECOND.

    you should get the erase screen at that point.

  3. #3
    Registered User
    Join Date
    02-05-2002
    Location
    Austin, TX
    Posts
    45
    Marc,

    That is in fact the process I am following. When I release the phone power button is when I get the

    FatalAlert
    DataMgr.c,Line:8589, Index out of range message

    If I try to hit the reset button (on screen) nothing happens at that point. I have to perfrom the reset using the up arrow key/reset process to get to a point to even uise the phone.

  4. #4
    Administrator
    Join Date
    10-21-2001
    Posts
    26,048

    Arrow

    hmm.. so the warm reset wokred for you but not the cold? a little strange. how far can you get in the process of using the phone when you do the warm reset?

    if all esle fails, you can take the battery off and let the internal battery drain, that will definately restore it back.

    can you use the phone regularly without having to do any resets? if you can, thendelete everything manually yourself and try a cold boot after that.

  5. #5
    Registered User
    Join Date
    02-05-2002
    Location
    Austin, TX
    Posts
    45
    Most functions of the phone work fine...just most/some of the wireless web features do not work. I get a fatal error.

    I'll try both of your suggestions and let you know. How long does it have to go without power for the internal battery to drain

  6. #6
    Administrator
    Join Date
    10-21-2001
    Posts
    26,048

    Arrow

    sorry for the late reply...

    it wil take atleast a day and a half...

    thats why i asked if you could use the phone.. just go in and manually delete all the apps then perform the cold boot.. see if that will clesan it out...


    you may also try "uninstall" hack...

  7. #7
    Registered User
    Join Date
    12-24-2001
    Posts
    179

    Can't do a hard reset... HELP!

    The unit goes to a soft reset no matter what I do.

    Any ideas that don't involve the use of a hammer?
    The older I get, the better I was...

  8. #8
    Administrator
    Join Date
    10-21-2001
    Posts
    26,048

    Arrow

    you probably have a bad app on the phone. a complete cold boot and manual restore are in order...

    what were you doing prior to the reset? what did yuo install... do you do anything to initiate the soft reset or does it do it randomly on its own?

  9. #9
    Registered User
    Join Date
    12-24-2001
    Posts
    179
    THIS WORKED, but I have no idea as to what's important and what's not. It took three hands:

    1. Remove battery
    2. Hold PWR button
    3. Paperclip the RESET function and hold
    4. Insert battery
    5. Release PWR and RESET
    6. Face east and pray

    Voila -- UP button and away!
    The older I get, the better I was...

  10. #10
    Administrator
    Join Date
    10-21-2001
    Posts
    26,048

    Arrow

    removing the batery is nothing more than a soft reset.

    you performed a cold boot it seems...

    i think probably the fact that it took some time for you to perform all the functions is why it worked in the end...

    but hey, whatever works right? :p

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts