I have noticed the following with my 650 on Verizon. When I tell the World Clock application to set the clock on my phone by checking the "Enable Local Network Time" box, I get the correct time, but the location is set to Denver, even though I am on the West Coast (It should be San Francisco). As a result, all the times for other time zones are based on Denver, so they are all one hour too early.
I have temporarily fixed this by unchecking the above option and entering the correct location/time info.
I have done a *228 and also a roaming programming.
Anyone familiar with this problem? Should I call Verizon and try to explain it to them?
I'd like to get this to work properly, so when I travel the phone will automatically update for the locale time and location.
Thanks.
Mike